M5stack core doesn't work online: ""No permission. The device has been bound!""

  • Hello all,

    I'm new to using M5stack core (the first and basic one). I installed the driver and followed the tutorials, everything was ok until I tried to connect and run a program from the M5Flow to the core in online mode. When I trying to connect or run a program the interface said the following message:

    "No permission. The device has been bound!"

    in the corner, where is the API KEY, it said the word "disconnected", if I press "refresh", it turned for a while in "connecting" and then go back to "disconnected"

    The interesting part for me is that if I do it offline, everything works fine but when I want to work online I got this message.

    I searched at the forum and in google and found no answer. Can anyone help me?

    In advance thank you so much.

  • try re-burning the firmware and putting the new api code into uiflow

  • Thank you for your reply "ajb2k3". I re-burned the firmware and also got a new API code and still get the same messages. Is any other idea?

    In advance thank you all the community for the suport.

  • @huberth16
    It may be linked to another account.
    Try pressing unbind in the EzData field for the linked account.

  • The same problem happened to me, no way to unbind the device unless yuo share with them ( M5stack support team) your device's MAC address or API while you keep your device online, so they can unbind it

    that what happened with me

  • @isamalatby Do you have a new device or second hand device?