Arduino IDE Configuration for Core2

  • I have the following additional boards in my Arduino Preferences:

    Do I need any other additional board libraries to successfully compile a Core2 project?

  • Hello @jdonth

    that boards URL worked for me.

    Here are the steps for the M5Core2 factory test. And yes, I have speaker output and the mic works too.

    Note: I am on Ubuntu 20.04

    • Download and install Arduino IDE 1.8.19
    • Run Arduino IDE
    • Open Preferences
    • Open Boards Manager
      • Search for 'M5Stack'
      • Install M5Stack v2.0.1 <-- (if you want to try an earlier version change this to let's say v1.0.8 - then you can copy all the files and skip fixing the sketch)
    • Open Library Manager
      • Search for 'M5Core2'
      • Install M5Core2 v0.1.0 (I selected install M5Core2 only)
    • Save already open Sketch as 'Core2_Factory_test'
    • Close Arduino IDE
    • Copy all M5Core2 factory test files into <home>/Arduino/Core2_Factory_test (except ft6336_fw_updater.cpp - has errors when using v2.0.1)
    • Open Arduino IDE
    • Select Board: 'M5Stack-Core2'
    • Fix Sketch (only needed when using v2.0.1):
      • In Setup():
        • comment out: ft6336_fw_updater();
      • In InitI2SSpakerOrMic():
        • after the line: tx_pin_config.data_in_num = CONFIG_I2S_DATA_IN_PIN;
        • add this line: tx_pin_config.mck_io_num = GPIO_NUM_0;
    • Compile Sketch (ignore warnings)
    • Connect M5Core2
    • Select port
    • Download and Run Sketch


  • @felmue
    OMG! It worked!!!!
    Thank you, thank you, thank you.

  • @felmue
    These instructions should be posted as a Core2 Sticky. They would go a long way to provide an outstanding starting point for all the new M5Core2 developers.

  • Hello @jdonth

    happy to hear it finally works for you. Thank you for letting me know.

    Happy New Year!