GestureUnit with AtomLite

  • Hi,

    I can't use the GestureUnit with the AtomLite.
    Is there anything I can do?

    I tried ...
    AtomLite & GestureUnit & some Arduino Lib -- failed!
    AtomLite & GestureUnit & UIFlow 1.8.9 -- failed!
    AtomLite(G25&G21 pins for i2c) & GestureUnit & UIFlow 1.8.9 -- failed!
    AtomLite & "TofUnit" & UIFlow 1.8.9 -- worked!
    M5Stack & GestureUnit & UIFlow 1.8.9 -- worked!
    M5StickPlus & GestureUnit & UIFlow 1.8.9 -- worked!
    Another AtomLite & GestureUnit & UIFlow 1.8.9 -- failed!

    I put only "gesture_0 begin" at UIFlow and I get below.

    Traceback (most recent call last):
    File "flow/", line 82, in _exec_fun
    File "<string>", line 6, in <module>
    File "", line 144, in get
    File "<string>", line 1, in <module>
    File "units/", line 20, in init
    File "units/", line 26, in _available
    Unit: Gesture unit maybe not connect


  • Hello @water5

    hmm, not sure why it would fail when used with UIFlow. I assume you selected port A for the gesture unit, correct?

    Note: there is always the possibility something's broken in UIFlow. I don't have a gesture unit so I cannot test myself whether it should work or not with UIFlow.

    For Arduino it should work after disabling internal I2C (not used in AtomLite) and starting I2C on Groove port A with this statements in setup:

      M5.begin(true, false, true); // turn off internal I2C
      Wire.begin(26, 32); // Groove I2C on port A


  • Hello Felix,

    Yes, I use port A for the gesture unit.

    According to my results, I suspect that there is compatibility problem bitween AtomLite & GestureUnit.

    Does anybody use a AtomLite & a GestureUnit?


  • Hello @water5

    today I got my gesture unit and I can confirm that it works fine with M5Core2 but fails to work with M5AtomLite using UiFlow firmware 1.9.8.

    What I found however is, that the gesture unit starts to work with M5AtomLite as soon as I add another I2C unit. I also double-checked with an I2C scan: only gesture unit connected to M5AtomLite and the scan finds nothing. Gesture unit and PbHub connected to M5Atom and the scan finds both. Go figure...