M5Paper on macos Big Sur



  • I am unable to connect to my m5paper on Big Sur.
    I've installed CP210x_VCP_MacOS.zip
    When the device is connected I can see a new device: /dev/tty.usbmodem52D40004421

    However I cannot connect to it with m5burner or uiflow desktop IDE.
    I have disable checking third party software and allowed software from "any".

    I have tried multiple cables.
    USB C to USB C cable
    USB C to USB A (with an adapter) cable.

    Any other suggestions ?


  • M5Stack

    can't connect it to the M5Burner? why? when uploading the firmware it has some abnormal situation? could you say more detail. also. if you wanna connect to the Desktop IDE you need setup the device to the USB mode. we suggest you use the online version.



  • I would love to use the online version, but I understand that I need the API key.
    To get the API key I have to update the firmware, right ? I don't see any other way to get the API key.
    (I have the m5paper 1.1)

    When I start m5burner and select the device port "/dev/tty.usbmodem52D40004421" nothing happens. No error message. No options to apply another firmware.

    When I try the same device in the desktop IDE, it says failed to connect, check that the device is turned on.
    How do I set it to USB mode?

    (I will upload some screenshots in a couple of hours)



  • Have you restarted the Mac? USBmodem is the wifiadapter on the Mac
    It looks like the driver has been updated and is playing silly again.



  • USBmodem is the wifiadapter on the Mac

    That does not seem to be the case

    Before connecting the M5paper
    ❯ ls -l /dev/tty.*
    crw-rw-rw- 1 root wheel 20, 0 23 Sep 20:16 /dev/tty.Bluetooth-Incoming-Port
    crw-rw-rw- 1 root wheel 20, 2 23 Sep 20:16 /dev/tty.WI-C200-serialport

    After connecting the m5
    ❯ ls -l /dev/tty.*
    crw-rw-rw- 1 root wheel 20, 0 23 Sep 20:16 /dev/tty.Bluetooth-Incoming-Port
    crw-rw-rw- 1 root wheel 20, 2 23 Sep 20:16 /dev/tty.WI-C200-serialport
    crw-rw-rw- 1 root wheel 20, 4 24 Sep 19:24 /dev/tty.usbmodem52D40004421

    0_1632508056338_Screenshot 2021-09-24 at 19.25.37.png



  • To answer you other question, yes, I have restarted the laptop.
    I did a power off, then power on with the physical button. (not just a reboot)



  • This is the screenshot of the error from the IDE

    0_1632508697935_Screenshot 2021-09-24 at 19.32.20.png



  • @nigel this message is a nightmare as it often means that there is a server issue but it could mean other things



  • Are you using safari because safari on OSX is seriously broken at the moment.



  • @ajb2k3
    That's the desktop application installed locally.
    I can't use the web UI Flow. I need to update the firmware to get the API key.
    I can't update, because I can't connect with m5burner.


  • M5Stack



  • @m5stack

    I have followed the instructions. As I can see the driver is installed :
    ❯ ls -ld /Library/Extensions/Si*
    drwxr-xr-x 3 root wheel 96 3 Nov 2016 /Library/Extensions/SiLabsUSBDriver.kext

    The application is in the applications folder as well :
    0_1632670382430_Screenshot 2021-09-26 at 16.30.25.png

    Factory test on the device looks good
    0_1632670563909_WhatsApp Image 2021-09-26 at 16.34.57.jpeg

    I have also tried uninstalling the driver. Reinstalling and rebooting.

    Any other suggestions ?



  • @m5stack
    I suppose the drive isn't loading, so I tried to load it on the cli :

    sudo kextload /Library/Extensions/SiLabsUSBDriver.kext
    Password:
    Executing: /usr/bin/kmutil load -p /Library/Extensions/SiLabsUSBDriver.kext
    Error Domain=KMErrorDomain Code=71 "Unsupported Error: one or more extensions are unsupported to load Kext com.silabs.driver.CP210xVCPDriver v4.10.14 in executable kext bundle com.silabs.driver.CP210xVCPDriver at /Library/StagedExtensions/Library/Extensions/SiLabsUSBDriver.kext" UserInfo={NSLocalizedDescription=Unsupported Error: one or more extensions are unsupported to load Kext com.silabs.driver.CP210xVCPDriver v4.10.14 in executable kext bundle com.silabs.driver.CP210xVCPDriver at /Library/StagedExtensions/Library/Extensions/SiLabsUSBDriver.kext}

    Does the driver support Big Sur 11.4



  • Ok, I have found that there is currently an issue in OSX in that the driver is randomly not being loaded for the adapters.
    As typical Apple have broke something.



  • @ajb2k3 said in M5Paper on macos Big Sur:

    Ok, I have found that there is currently an issue in OSX in that the driver is randomly not being loaded for the adapters.

    It consistently fails to load, not randomly. At least that's the case for me.
    What's your source?

    @m5stack Can you confirm is this was tested on Big Sur 11.4 ?
    Unless someone can confirm they have has it working on that specific version it's more than likely the driver was not built for this OS.

    There are over 550 kernel extensions on my mac and they all work perfectly. It seems the interface Apple exposes for loading extensions works for everyone else.



  • @m5stack
    For general information Silicon Labs has a newer version of the driver which I can load.
    But that does not work either :(

    https://www.silabs.com/developers/usb-to-uart-bridge-vcp-drivers



  • Was working on 10.14 but 10.15 fails.



  • @ajb2k3

    I'm on 11.14 Big Sur

    10.14 would be Mojave released in 2018

    @m5stack
    At this point I can only assume recent macos is not supported and I'll and get my hands on a windows computer :-(



  • @nigel Im on Catalina (just upgraded from Mojave) and now have the issues :(