Core2 keeps rebooting with PoE base

  • I am trying to get Core2 working with PoE base, but when powered from PoE it doesn’t start. Core keeps power cycling on PoE, but works just fine with external power.
    Tried with 2 different cores and 2 different bases.
    Also tried with different PoE switches/cables.

    Original core works fine in the same setup.
    When powering from USB-C Ethernet from PoE base works fine.

    What could be the reason why it doesn’t work?

  • Hello @e-d

    have you tried to change the fifth (last) parameter of M5.begin() to kMBusModeInput?

    Explanation: M5Core2 starts to boot up from external power (e.g. from PoE), but when M5.begin() is executed (which uses kMBusModeOutput by default) that changes the power source to either battery or USB (which are not present) and thus M5Core2 reboots and so on.


  • Hello Felix,

    Thank you, I will try this! Is this documented somewhere? Just curious how to learn about these parameters and what are the other parameters.

  • Hello @e-d

    I don't think this particular parameter has been documented (yet) for the LAN PoE module. It has for some of the newer COMX modules which also can be powered externally.

    Another reason, I guess, is, that with M5Stack devices (Fire, Gray, Base) there is no need to switch between output and input as they use a different electrical circuit than M5Core2, which allows the power pin to be both (input and output) at the same time.

    As for learning about these parameters - sometimes looking at the Arduino libraries and / or schematic helps figuring out how things are meant to work.