Core 2 looks dead, is it bricked? - fixed

  • Hello guys,

    I use an Core 2 and tried to install a programm via the Arduino IDE and now it looks dead. Previously it was working fine, Factory test, UIFlow etc. looked good.

    If I try to switch it on nothing happens, no display, no LEDs, nothing. Arduino IDE and VS Code are not able to connect to the Core2 anymore (is worked before). Output VS code:
    CURRENT: upload_protocol = esptool
    Looking for upload port...
    Auto-detected: COM4
    Uploading .pio\build\m5stack-core2\firmware.bin v3.1
    Serial port COM4
    A fatal error occurred: Failed to connect to ESP32: Timed out waiting for packet header

    I removed the M5Go2 botton to remove all the internal power supply, and connected it to the USB. But still nothing, no LEDs, no LCD, no connection.
    Next I tried the M5Burner, but the result is still a failure.

    The COM-Interface is still available:
    COM4 Silicon Labs CP210x USB to UART Bridge (COM4) USB VID:PID=10C4:EA60 SER=02160F7D LOCATION=1-14
    Is there a chance to fix this issue an resurrect my Core2?

    Thanks a lot,

  • Try downloading M5Burner from the M5Stack and reinstalling the UIFlow firmware for Core 2 then try reloading arduino.
    Have you tried unplugging and plugging or restarting the computer?

  • Hello ajb2k3,
    thanks for your reply! I also tried the M5Burner with different speeds 16MBit/s, 115200 bit/s, but the result is the same:

    Start Burn
    --chip esp32 --port COM4 --baud 115200 --before default_reset write_flash -z --flash_mode dio --flash_freq 80m --flash_size detect 0x7ff000 C:\Users\urwaldfloh\Downloads\M5Burner\packages\fw\other\wifi.bin 0x1000 C:\Users\urwaldfloh\Downloads\M5Burner\packages\fw\core\UIFlow_Core2-v1.8.0-core2.bin v2.5.0
    Serial port COM4
    .... [..].._____
    A fatal error occurred: Failed to connect to ESP32: Timed out waiting for packet header
    Burn Failed

  • Have you shut the computer down, the restarted and used the "Cold boot" method to reinstall the driver?
    Have you tested it with another Computer?

  • I tried a "cold boot" of my windows system, but without any success. Then I tried it with my linux mint notebook, also no success.
    But I found out a very interesting fact: It is not (totally) bricked =)
    When I start the serial terminal (e.g. putty) and connect to the M5Stack the PC receives "Hello" periodically.
    Hence the hardware is not totally broken, but connecting to the M5stack is still not possible. This could be the last program before it "died".
    Maybe the periodically "Hello" message blocks the new program download. Is this even possible?

  • @urwaldfloh yes it possible and that would explain why it cant update because the terminal is busy
    In M5 burner, did you try erasing the firmware before flashing? the erase button is sometimes hidden.!0_1627112506601_Screenshot 2021-07-24 at 08.41.24.png

  • @ajb2k3 It worked!! Thanks a lot! =)
    It took several tries to erase the M5, but suddenly it worked. I installed the factory test and it was also a success. I'm so happy!

    Can you give me any suggestion that this does not happen again? I use the serial terminal for debugging very often and it would be a little drawback developing without it.

  • @urwaldfloh Glad to hear it. unfortunately I can't think of any tips that may help