Tailbat Grove port bad electrical connection to atom

  • I've just tried using my atom tailbats with a new OLED Unit and spent a long time wondering why the tailbat grove port didn't seem to work with the OLED.
    The USB power and grove connector have really bad electrical connections on my newer matrix atoms (with diffused plastic over the LEDs). This stops the pass-through grove port from working properly unless I press the atom down onto the tailbat quite hard and hold it. The USB connector for the atom power usually works fine, but the atom grove pins don't connect cleanly to the tailbat. If I press too hard then the USB power connection fails and resets the atom (obviously). This is a really bad mechanical design which doesn't use a proper grove socket, it is done with a similar 4-pin connector socket with the correct pin pitch, but it is not grove.

    I have just tried a couple of older Atom Matrix cores (with clear plastic over the LEDs) and the grove connector pins on the older Matrix Atoms are very slightly longer and make a better connection. With those, the OLED shows my test animation every time. It also works with an atom lite.

    This is not good as I don't know how I can make all the USB power pins and grove pin connections reliable without touching or holding anything. Both USB power and all the grove pins need to work and both of the different connectors need to be in exactly the correct position at the same time. You can't really adjust anything on the tailbat connectors, they are fixed in place. It's difficult to see how the connections could be done with 'proper' grove and USB extension cables to the battery instead of the direct dual connectors. Putting some sort of kludge board between the atom and the tailbat is also a bit of a ridiculous solution, the tailbat and pass-through grove connector should really work on any atom, every time. I could just use the built-in grove port and a USB powerbank (if I can make it stay powered-on all the time).

    Anybody else have anything similar? There are some other posts here that tailbats were not working properly, I wonder if some of those problems were actually the same bad mechanical connection issue?

  • check the soldering of the connectors on the tailbat as i had the datapins break