Atom Tailbat not charging anymore

  • I have the Atom Tailbat and it does no longer charge. When I connect it to a power source it is blinking and even afert several hours it does not stop blinking. The charge is empty when I connect an Atom to it. I tried to charde it with and without Atom Lite connected and got the same result. Can I reset it somehow? Or is the battery worn out?

  • Hello @fjamitzky

    I don't have an Atom Tailbat, but it sounds like the battery is either dead or got disconnected somehow.


  • Hello, how long you've had the module? it does sound like the battery have been worn out. have you been leaving it away for quite some time? this could be one of the reasons.

  • I know this topic is half a year old, but this info may be important for anyone searching this.

    I have the same situation with a Tailbat that is just a couple of days old. When USB-C is plugged in, the red light blinks less frequently (once every 2 mins) than with a working battery. The attached atom lite remains off, but works if I power it directly. I think I broke the battery after accidentally swapping the poles in the USB cable for charging. Is there any way to open and repair it?