DC Motor AKA Lego+ not working in uiFlow?

  • Re: LegoBoard

    Having updated everything (v1.7.2 for the firmware, and using the beta as well as the non-beta v1.4.5 of the uiFlow), I cannot seem to make the Lego+ (AKA DC Motor in the newer UI) work. All I get is "legoBoard not support in uiflow" on the LCD of the M5 Core unit.

    I remember it did work a long time ago. What changed, and more importantly: how to fix this?

  • Hello @hkubota

    yes, it looks like Lego+ has been broken in recent firmware as I get the same error on M5Stack Gray or M5Core2 running 1.7.2 firmware. However when I burn 1.4.5 firmware onto my M5Stack Gray I get a different error stating that the Lego module maybe isn't connected (which is correct as I don't have a Lego module).

    It might be worth trying to burn 1.4.5 firmware onto your M5Stack and try again.


  • @felmue That actually worked. Not an ideal situation as I cannot use the newer units, but for now the Lego motors turn again which is awesome!
    Thanks a lot! I downgraded the UI, but it never occured to me that I should downgrade the firmware too.

  • Bangalore Escorts in Just One Call..
    Hi Guys, Nikitha Bangalore Escorts agency is one of the most popular Bangalore Escorts Service. The girls of our agency are not just beautiful enough but also proficient in the art of providing best erotic service.