ATOM can't connect to wifi anymore

  • Hello,

    I have 2 M5Atom Matrix since the beginning of the year, all my tests used only one. After trying uiflow, I started to have wifi connection issues: my board never connected to Wifi anymore.
    Back to PlatformIO, same issue
    Back to Arduino, even with the "WifiClient" example, same issue, suck when trying to connect. However, the "WifiScan" sketch is working fine.

    I tried to erase the chip, and try also the second board, same issue!
    I verified my access point which is "WPA2-PSK / AES", channel 6 (not exotic). I tried a second access point using my phone. no success...

    any clue?

  • Hello,this is very strage as it sounds you can connect to your device and scanning shows the wifi chip is working.
    could you please try to deactivate the password from your access point and connect without a password? see if it can solve the issue?

  • Hi zontrex,
    your idea pushed me to test more.
    After trying open wifi without success, I decided to display WiFi.status(): this was 6, with a comment on a page "maybe not in Station Mode"
    So I added WiFi.mode(WIFI_STA) before the WiFi.begin(), and it worked !
    Thanks for you support.

  • Hmm
    Maybe I wrote too fast, because when coming back the my original code, I had the WiFi.mode(WIFI_STA)...
    I keep you in touch

  • Very weird...
    After some other tests, I did not find why it's working, but it is !

    It was not working until I added WiFi.setHostname() before begin(), but it is still working after commenting it...