UnitV unable to install firmware



  • My UnitV is not discoverable by M5Burner and EasyLoader. I installed the CP210x driver and have no problems connecting and burning firmware to my M5Stack Grey. I'm on Widnows 10 and the device is visible by Windows in the Device Manager:

    0_1606290429188_obraz_2020-11-25_084709.png

    The COM port does not show up in M5Burner and EasyLoader. Seems that UnitV is not discoverable. Any suggestions on fixing this?


  • Global Moderator

    Hello, have you tried restarting your computer after installing the CP210X driver? please restart and let me know if the issue still persist. thanks!



  • I resterted the computer and also updated M5Burner to the latest version. No success so far, UnitV is still not discoverable.


  • Global Moderator

    Do you own any other M5Stack devices with the CP210x chip? I just want to understand if it's related to the hardware or to the software, if it's hardware issue than if you plug any other CP210x M5Stack device to your computer it should work fine, if its software issue no CP210x will work for you, theoretically.

    Could you please let me know if you have other device to plug in and test?

    also, do you have other machine (PC) to test it on?



  • I'm working with my M5Stack Grey and have no problems, it always appears as one of the COM ports. M5Stack Grey works perfectly fine with my machine.


  • Global Moderator

    @adamm Hi Adam, please send me email to roni@m5stack.com and I will personally take care of this issue for you.



  • This problem is solved now. The following instruction needs to be updated:
    https://docs.m5stack.com/#/en/quick_start/unitv/v_function
    The instruction does not specify what driver is needed to communicate with hardware. It came out that the user needs a different driver than the one used for M5Stack core products.
    In case anyone has the same problem, please make sure you have the newest VCP driver by FDTI installed on your machine. My advice is to use their website to check out the latest version:
    https://www.ftdichip.com/Drivers/VCP.htm