Running UIFlow desktop IDE in Linux

  • Hello, I am new to the world of M5Stack and have run into a problem. I have searched in this forum, Facebook groups and online in general but so far I haven't found a solution. I use Linux (Ubuntu 20.04) and having an issue when running the UIFlow desktop IDE. Everything seems to be working fine except when I try to open an existing project from disk.

    From both the folder icon at the bottom of the screen or via the menu in the top right corner I get to the point of the file selection dialog window will open and then immediately everything will freeze, not just in UIFlow but the whole system. I have tried both Ubuntu 18.04 and 20.04 with the same result.

    Has anyone else experienced this or have any suggestions where to look so I can search some more.

    Thank you for any help.

  • @glenj Hi Glen, sorry to hear about the problem you are having. could you please clarify what exactly freeze? does your web browser crash and freeze or is it the M5Stack Device? are you able to use the web browser after it happens or you need to restart it? have you tried changing web browser or using a different project file?

    would you mind providing some information about the project file you are trying to open so we could try to replicate it and see what's goin on?

    Looking forward to assist you,
    ~ Roni

  • @zontex Hi Roni, thank you for the reply. I am not using the browser version but am trying to use the offline desktop IDE. I start the UIFlow program from a terminal, it loads and everything appears to work well. I can write a program in Blockly and run it on the Core2 device, download it to the device and run it as well.

    If I have a project on disk and want to load it then that is where my problem is. When I go to open the .m5f file as soon as the file selection window opens it locks up and I am almost unable to do anything at all (my whole system, not just in UIFlow). I can switch back to the terminal window and close UIFlow then once I have done that my computer is back to normal.

    This happens with all projects not just mine, even a simple 1 line test project. I create a project to print 'Hello World!', I can save it to disk but if I try to open it from disk I have this problem.

    Thank you for your help.

  • Working some more on it I have found I am able to close the file selection window (using Alt+F4) and can return to the UIFlow program so it appears to be an issue while the file selection dialog window is open.

  • @glenj Hi Glen, glad it worked out, we will look into that IDE bug to see what's going on.

  • @zontex It hasn't really worked out yet. I am able to close the file selection window that is all, I still can not select a file on disk and load it.

  • @glenj said in Running UIFlow desktop IDE in Linux:

    @zontex It hasn't really worked out yet. I am able to close the file selection window that is all, I still can not select a file on disk and load it.

    Noted. sorry for the misunderstanding, I thought you said once you press ALT+F4 you can close the dialog and upload the file successfully, I will dig deeper and take a look into it, will let you know the results. could you please let me know what version of UIFlow you are using?

  • @zontex I have version 1.0.13

    Thank you

  • @glenj Hi Glen, I reproduced the issue on Ubuntu and having the same issue as you, it does seem to be a problem in the IDE. The problem doesn't appear to be on OSX or Windows - both are working fine. I'll look into it to figure out a solution and get back to you, thanks for letting us know!

  • @zontex I have set up another PC with Windows and as you said everything is fine there, I just prefer not to use Windows. I also tried the web version on my Ubuntu machine and everything works well there as well.

    I will wait to hear from you when a solution for the Linux Desktop IDE is available.

    Thanks again.

  • Same Problem here with Ubuntu 18.04. LTS.
    Its using nautilus as the default file manager. But the problem is not
    on nautilus. I changed the filemanager to nemo and krusader and the
    same bug appeared. Must a bug in UIFlow for Linux :(

  • Same issue here, under Ubuntu 17 and 18, freezing UIFlow when opening the file selection menu. There is also an error with M5Stack Burner with an incompatible GLIBC library. Both errors together makes it difficult to use Linux Ubuntu for M5 Stack development tasks. Please assist as Linux Ubuntu is my preferred development platform.