Can't flash the M5stack FIRE

  • I am sure this issue has been talked over many times, however I was never able to flash My M5stack FIRE. I can erase it but when I click on "burn", after selecting the UIflow-1.2.3, it tells me " you must 1st download this firmware before burn it " Didn't I do that by clicking the down arrow next to the selected firmware ? Is it an download directory issue ?
    Thank you for any help on this. Extremely frustrating to get such behavior nowadays...
    Best regards

  • @alpine-lake have you tried 1.4.1beta?
    Have you waited for the firmware to actually download from the server?
    Sometimes the program can take ages to download firmware but when complete the text will turn white.

  • Hello there and thank you so much for your reply.
    It appears do have downloaded as the down arrow reverts to the inactive state.
    What I fail to understand is where this firmware is supposedly downloaded.
    The environment should be part enough to put the firmware file in the right place. Perhaps I am mistake in assuming that ?
    Do you know the name of the firmware file so I could try to locate it ?
    Also, if you have a working setup would you please be so kind as the show me how the directories and organized so I can see the location of the different files ?
    Thank you in advance for your assistance.
    Best regards

  • @ajb2k3
    Hello again, I tried again and indeed the firmware text didn't turn white. How long should I wait based on your experience ?
    Kind regards

  • @alpine-lake
    Nah... Simply doesn't work . Waiting the M5 support's suggestions. I don't have much hope though as they couldn't help before.

  • @Alpine-Lake which operating system are you on? If on Mac Uiflow software must be in the applications folder for the firmware burner to be able to download the firmware files and function properly