M5Stack Grey module ... OSError: [Errno 2] ENOENT



  • Hello,

    I recently bought this item and out of the box (by the way, the battery was empty) I got that message. Since I am not familiar with ESP32 yet and I am in a bit of a hurry, I wasn't checking the whole forum -- whether this issue is posted somewhere -- and I apologize for that. I would like to know whether this Grey module can be "repaired", or do I need a new one? If it could be fixed, can you, please, help me with that? Thank you.

    0_1551189106480_3.jpg


  • M5Stack

    @venetomi This is normal, It seems as though you were sent a grey that would usually be paired with a keyboard module, so the firmware takes you straight into REPL mode, but you can flash it with any firmware you want.

    If you want to program the device with Arduino or Uiflow(block programming) please refer to the guides on this page https://docs.m5stack.com/#/en/quick_start/m5core/m5stack_core_quick_start

    any other questions please don't hesitate to ask around in the forums, if you do a quick search you can usually find what you need to know here



  • @lukasmaximus Thank you very much for you help, Lukas. Just that I know it's not something detrimental. My Grey module is a part of Faces; I posed a question here since there's no M5stack Faces theme in /Cores, and I didn't want to open a new theme since it's the same module. Thanks again.



  • Hi guys! I have been looking for a way to get my Faces back to this REPL mode... is there a way to do this? Is there a benefit to this? I would like a way to practice python on the go, and if I could do that by putting my Grey core back to REPL mode that would be awesome! Am I understanding correctly? or should I just focus on UIFlow? I did a google search for that ENOENT error and it looks like it has something to do with a missing main.py file. Im thrilled to learn more about the M5Stack and microPython. Thanks for your help.


  • M5Stack

    @pbdevastator 0_1552974229447_repl.JPG

    Try the lastest M5Burner

    the factorytest firmware is REPL mode



  • IT IS NORMAL...