M5Stack FIRE stopped working with USB power



  • Until some minutes ago, everything worked perfectly fine, but suddenly the M5Stack (alone, as well with modules attached), stopped working while connected to a USB port of my computer and/or charger.

    When I connect a battery and disconnect the USB cable, it boots up. As soon as I reconnect the USB cable, it switches off... Remove the USB cable: It boots again...

    The USB serial port is still visible when connected to the computer, but there is no response from the ESP. To me this looks as if it is really without power supply. Is there some comparator IC, which selects the power source, which might be confused?

    Does anyone have any ideas what the problem could be and how it could be fixed?


  • M5Stack

    @tkl Does this problem recur?


  • M5Stack

    Hi @tkl can you communicate with the device over serial when the usb cable is attached. Which version of the M5stack are you using? fire, gray, basic? have you tried other usb cables?