M5Stack incompatable with Arduino 1.8.8.Release



  • Just had to rebuild my arduino and found all the M5 stack is comming up in the "Incompatable" list.

    Use the Hourly build and it works but RTOS doesn't work with either builds :(


  • M5Stack

    Thanks for the notification, I'll test this today


  • M5Stack

    Hi @ajb2k3 myself and @watson both tested the new IDE with multiple different models of the M5stack on both windows and Mac and didn't have any issues. Perhaps you could give us more info on your setup and perhaps a screenshot or copy and paste of the exact error message.

    Thanks



  • @lukasmaximus said in M5Stack incompatable with Arduino 1.8.8.Release:

    Hi @ajb2k3 myself and @watson both tested the new IDE with multiple different models of the M5stack on both windows and Mac and didn't have any issues. Perhaps you could give us more info on your setup and perhaps a screenshot or copy and paste of the exact error message.

    Thanks

    I've got both the 1.8.8 version and just updating to the latest hourly version.
    freertos10.1.1-1 from the official libs


  • M5Stack

    @ajb2k3 said in M5Stack incompatable with Arduino 1.8.8.Release:

    freertos

    Could it be that the compatibility issue is with freertos then and not the arduino IDE, I'm not so familiar with freertos to be honest so I would not know where to start on testing. Looks interesting though, is freertos the framework that the multiapp and M5EZ firmwares are built upon?



  • @lukasmaximus said in M5Stack incompatable with Arduino 1.8.8.Release:

    @ajb2k3 said in M5Stack incompatable with Arduino 1.8.8.Release:

    freertos

    Could it be that the compatibility issue is with freertos then and not the arduino IDE, I'm not so familiar with freertos to be honest so I would not know where to start on testing. Looks interesting though, is freertos the framework that the multiapp and M5EZ firmwares are built upon?

    Sorry, its the examples that are coming up in the "INCOMPATABLE" list along with the freertos examples.

    Hmn, I wonder if this is connected to the board selected as the gui is doing some wierd things since 1.6



  • @ajb2k3 said in M5Stack incompatable with Arduino 1.8.8.Release:

    @lukasmaximus said in M5Stack incompatable with Arduino 1.8.8.Release:

    @ajb2k3 said in M5Stack incompatable with Arduino 1.8.8.Release:

    freertos

    Could it be that the compatibility issue is with freertos then and not the arduino IDE, I'm not so familiar with freertos to be honest so I would not know where to start on testing. Looks interesting though, is freertos the framework that the multiapp and M5EZ firmwares are built upon?

    Sorry, its the examples that are coming up in the "INCOMPATABLE" list along with the freertos examples.

    Hmn, I wonder if this is connected to the board selected as the gui is doing some wierd things since 1.6

    No, but it seams to be a core used with the IDF examples.
    I'm still trying to crack the camera to use the Arduino GUI instead of the commandline/IDF combo.



  • I'm getting so far and then I hit the "Invalid conversion" error and get stuck as I dont understand the issue.


Log in to reply
 

Looks like your connection to M5Stack Community was lost, please wait while we try to reconnect.