Warranty question M5stack is dead

  • I was wondering what the Warranty is for the M5sstack. I have purchased may accessories and the the Fire module but the original unit I bought on Amazon from Maker Focus in late January just quit powering up. It is simply bricked. I was working fine a few days ago.

  • Does it appear on a computer when you plug it in?
    Have you tried uploading a program without connecting a battery?
    Have you tried another usb to uart adapter to connect to the M5?

  • It doesn’t appear on the computer. It doesn’t power up with 2 different cables and 2 different USB supplies or when plugged in to the computer USB or on the internal battery.

  • I plugged the M5Stack into a USB power source and measured the power pins with a DVM. The Battery pin measures 4.2V, the 3.3 volt pin measures 3.3 volts, and the 5V pin 5 volts. But the device does not power up.

  • I tried some additional troubleshooting. I removed the bottom battery slice and plugged the top slice into my computer. There is no connection to the device so nothing can be uploaded. The display is also dark in this configuration and with it plugged into a USB charger.

  • I seems that the problem resolved itself. This is very strange. I removed the battery slice several times but this did not resolve the problem. I even removed it once for at least a day. Finally I removed that battery slice and I let the unit sit for several days without the battery. When I reconnected the battery it started working link nothing ever happened.

  • @ispybadguys A Power supply problem, please contact to Hardware Engineer of M5Stack


与 M5Stack Community 的连接断开,我们正在尝试重连,请耐心等待