M5Stack MultiApp Advanced Firmware



  • Hi Calin , OK

    Download (and unzip) this repository ==> OK
    Download and Install Visual Studio Code https://code.visualstudio.com/ ==>OK
    Install the PlatformIO Extension ==> OK
    Install ESP32 Framework on PlatformIO ==> How TO ? no link and a lot of ESP32 framework

    thanks for help

    Regards



  • @picpic020960M5Stack MultiApp Advanced Firmware 中说:

    Hi Calin , OK

    Download (and unzip) this repository ==> OK
    Download and Install Visual Studio Code https://code.visualstudio.com/ ==>OK
    Install the PlatformIO Extension ==> OK
    Install ESP32 Framework on PlatformIO ==> How TO ? no link and a lot of ESP32 framework

    thanks for help

    Regards

    Go to Platforms
    Type in ESP32 on the search bar
    Click on Espressif 32
    Click INSTALL
    Wait to finish (this may take 1 - 5 minutes, depending on your internet connection speed)
    Done.

    0_1530807254012_ESP32Platform.PNG

    To open MultiApp Advanced project:
    right click on the project folder
    Select "Open in VsCode"
    VsCode will open and the project will be loaded in PlatformIO

    You don't need to install any library to compile the MultiApp-Advanced. All necessary resources are included into project.



  • Calin

    first compil :
    src\Apps\WiFiWps\WpsConnect.cpp:73:16: error: no match for 'operator=' (operand types are 'esp_wps_config_t' and '<brace-enclosed initializer list>')

    some mistake ?

    edit :
    commented ==> Build OK
    but how to load the firmware in the m5stack ?

    other question : how to apply the patch ?

    thanks for help

    Regards



  • @picpic020960M5Stack MultiApp Advanced Firmware 中说:

    Calin

    first compil :
    src\Apps\WiFiWps\WpsConnect.cpp:73:16: error: no match for 'operator=' (operand types are 'esp_wps_config_t' and '<brace-enclosed initializer list>')

    some mistake ?

    No. There is no mistake.
    PlatformIO updated the Arduino-ESP32 framework to new version.
    I updated the MultiApp firmware to work with this new version.
    If you use git, just pull the latest commit from github and recompile.
    If not, download the repository again then compile.

    edit :
    commented ==> Build OK
    but how to load the firmware in the m5stack ?

    Please READ the repository instructions !

    0_1530824824747_instructions.PNG

    other question : how to apply the patch ?

    The old patch is no longer needed... because Espressif fixed the GPIO39 bug on the latest arduino-esp32 framework.



  • Hi Calin

    when m5stack not connected i see ' <version....py>' at end of build report.

    (from memory , now at work , not at home)

    when m5stack connected i see nothing at end of build report.

    i have com1 and com4. how to choose ?

    thanks for help

    Regards



  • @picpic020960M5Stack MultiApp Advanced Firmware 中说:

    Hi Calin

    when m5stack not connected i see ' <version....py>' at end of build report.

    (from memory , now at work , not at home)

    when m5stack connected i see nothing at end of build report.

    i have com1 and com4. how to choose ?

    thanks for help

    Regards

    You don't have to chose anything.
    No need to select the upload port.
    PlatformIO will detect the M5Stack port automatically, once is connected to PC USB.



  • New version compilation results:
    M5StackMod initializing...[E][sd_diskio.cpp:739] sdcard_mount(): f_mount failed 0x(3)
    E (705) SPIFFS: mount failed, -10025
    [E][SPIFFS.cpp:47] begin(): Mounting SPIFFS failed! Error: -1
    OK
    [E][Preferences.cpp:330] getUShort(): nvs_get_u16 fail: light NOT_FOUND
    and nothing more...

    any ideas?



  • @kabronM5Stack MultiApp Advanced Firmware 中说:

    New version compilation results:
    M5StackMod initializing...[E][sd_diskio.cpp:739] sdcard_mount(): f_mount failed 0x(3)
    E (705) SPIFFS: mount failed, -10025
    [E][SPIFFS.cpp:47] begin(): Mounting SPIFFS failed! Error: -1
    OK
    [E][Preferences.cpp:330] getUShort(): nvs_get_u16 fail: light NOT_FOUND
    and nothing more...

    any ideas?

    Please update the Espressif 32 platform to latest version (v1.1.1 at this moment)
    That should solve the problem.



  • @calinM5Stack MultiApp Advanced Firmware 中说:

    Please update the Espressif 32 platform to latest version (v1.1.1 at this moment)
    That should solve the problem.

    I have 1.1.2 installed and do not know how to degrade
    P.S.
    degrade with
    platform = espressif32@1.1.1
    and now it works



  • @kabronM5Stack MultiApp Advanced Firmware 中说:

    @calinM5Stack MultiApp Advanced Firmware 中说:

    Please update the Espressif 32 platform to latest version (v1.1.1 at this moment)
    That should solve the problem.

    I have 1.1.2 installed and do not know how to degrade
    P.S.
    degrade with
    platform = espressif32@1.1.1
    and now it works

    I just tested with espressif32 V1.1.2 and work's just fine.
    Please download the latest repository commit and compile.
    it should work just fine.


登录后回复
 

与 M5Stack Community 的连接断开,我们正在尝试重连,请耐心等待