MQTT doesn't work



  • Error:MQTT need,download...


  • M5Stack

    Would be useful to know some more information, such as the firmware you are running and on which device. Also a snapshot of your code wouldn't hurt too. Just posting mqtt doesn't work, doesn't really help us to solve your problem



  • @sysdl132 said in MQTT doesn't work:

    Error:MQTT need,download...

    When using MQTT, you need to download the program to your device. You can’t just run your program with the play button.

    0_1580040034321_1218CEDE-FB01-41DF-89B9-EBC39CAC146F.jpeg



  • there is an another problem...
    0_1580461757076_bd043c6d-2476-4a8e-9082-4b3768f0a511-image.png
    Where is Unit earth`s port?



  • @sysdl132

    Seems to be a uiFlow bug. The Earth unit is a "port B" unit since it supports both analog and digital readings. If you go to settings and choose Device: core, the default port B shows up properly in uiFlow. But when you have Device: Stick-C, I see the same issue as you do. However, switching to the Python tab within uiFlow, it still shows the unit defined properly for the m5stickC since it only has one Grove port (A): earth0 = unit.get(unit.EARTH, unit.PORTA)
    If you have the Earth unit, please try it and see if it works properly so we can confirm it's just a display issue within uiFlow.