M5Stick C - Cannot flash firmware

  • Hi everybody,

    I received my M5Stick some days ago (and it is a so great hardware ! So tiny an nice !) but don't even succeed to flash it the UITools firmware. I think for the moment it is the hardware test which is installed and running (it tells "wifi test" and after "data" in green and red).

    I tryed with my MacBook Pro with MacOS Catalina, with Windows 10 on a VM and on a real PC with Windows 10 with no results.

    I tryed with M5Burner ans with Arduino IDE also.

    I tryed with the a wire connecting GND to G0 too.

    I tryed with another USB cable too.

    All the time the same error :

    • When the M5Stick is OFF:
    Serial port COM3''
    A fatal error occurred: Failed to connect to ESP32: Timed out waiting for packet header 
    • When the M5Stick is ON :
    Serial port COM3
    A fatal error occurred: Response doesn't match request

    The COM3 port is looking like that in the device manager (I installed the USB serial driver CP210X ) :
    alt text

    I didn't try to add a cap somewhere on the board like some folks did but I'm asking myself if this could be a solution.

    Could you please guide me ? I don't know what to test now.

    Thanks a lot

  • M5Stack

    1 . long press the power button, when the log show "Connecting.................._____."

    1. seting the upload speed to 115200

    2. connecting GND to G0 , when you upload program.

    3. could you erase the flash? then burn the firmware again?

    If none of the above works, please contact our store , thanks

  • Thanks a lot for your quick answer !
    With a long press on the power button, the error message is changing a little bit :
    alt text

    It can be red "Failed to connect to Espressif device" instead of "ESP 32".

    2/ I already use this setting
    3/ I already do it. Do I need to wire it for firmware upload (M5Burner) and programs (Arduino IDE) ?
    4 / When I erase the flash with M5Burner I have the same error. Ones I got "Finished" instead but after the flash was not erased and the usual hardware test pgm launched...

  • M5Stack

    contact the store , then them will help you solve .

  • I bought it on Banggood. I contacted them. The pb will be to ship another M5stick and wait for 3 weeks again... I'm in France.

  • Are you sure you set the correct baud rate in the flasher module? I had the same issue and reducing the baud-rate to 115200 worked for me.

  • I was having the same problem, but it's working now. I use a Macbook Pro running Catalina.

    Received my M5StickC today, and it looks great, but the Arduino AVR ISP and AVR ISP II programmers couldn't connect to it. I installed updated CP210X drivers, but that didn't help. Then I tried the suggestions from m5stack above, and when I connected G0 to GND, then clicked the "Upload" button in the Arduino IDE, it worked.