M5Stack Grey keeps running 'built-in' demo?

  • Hi,

    I have just got my M5Stack Grey but when I connect to the PC it runs the demo sketch.

    When I run UIFlow Desktop it sees COM11 but when I press "OK" it says "connecting M5 ..." then an error message pops-up saying "Unable to upload ...".

    The message at bottom left of UI says "COM11" [disconnected].

    Plesse help what have I missed, it is easier on the M5Stack Fire it has the option for USB mode, but the Grey appears not the same.

    I have pressed all the buttons while plugging in the USB cable but no joy.


  • Have you tried reflashing the firmware with M5Burner?

  • Thank you.

    Yes, but it fails saying no device attached.

  • Hi,
    I just received my grey yesterday and had same issue.
    You need to download and install offline version of m5burner and Ui Flow (available on m5stack.com)
    Ui Flow downloads and installs all necessar drivers for you. Attach module with usb, run M5Burner, select firmware you want, dont forget to set lowest speed possible (was 112500 for me). Now turn m5stack on with single press and same time hit BURN button on m5burner. Its a tricky part, you need to combine burn button with module boot period. Once you success with UiFlow firmware everything works flawless for me, any speed and such
    Good luck

  • @thrasher Hi,

    Thank you.

    I will give that a try.


  • Thank you Thrasher all working now.

    Burned firmware 1.3.2.


  • Great, glad to hear, enjoy it
    We better flood this forum with any type of questions to make it more active haha