I cannot upload anything on my M5Stack Fire



  • Hi, can anyone help me?!
    I cannot compile anything with the Arduino IDE, due to the the following message:

    Arduino:1.8.9 (Mac OS X), Scheda:"M5Stack-FIRE, Enabled, 921600, None"

    /Users/Fabrizio/Documents/Arduino/libraries/M5Stack-master/src/utility/Power.cpp: In member function 'void POWER::powerOFF()':
    /Users/Fabrizio/Documents/Arduino/libraries/M5Stack-master/src/utility/Power.cpp:360:35: error: 'ESP_SLEEP_WAKEUP_ALL' was not declared in this scope
    esp_sleep_disable_wakeup_source(ESP_SLEEP_WAKEUP_ALL);

                                   ^
    

    /Users/Fabrizio/Documents/Arduino/libraries/M5Stack-master/src/utility/Power.cpp:361:28: error: 'gpio_deep_sleep_hold_dis' was not declared in this scope
    gpio_deep_sleep_hold_dis();

    What is happening?
    I reinstalled the Silicon Labs drivers and the M5Stack library (version 0.2.8) but nothing changed...

    Thank you very much
    Fabrizio



  • @ferrianf your arduino install is missing the required librarys needed to compile the code.



  • @ajb2k3 I tried to reinstall Arduino IDE 1.8.9 and the library M5Stack, the only one included in my code but nothing changed, always the same error!
    Thank you for your help :(