Simple fix when upload fails.

  • This post is deleted!

  • @jimit Hi Jimit,
    I forgot to tell, that I am using the new 2018 model (with 9DOF-Sensor and USB-C). I have no Chance to press the Reset-Button in time , because there are only a few dots when "Connecting ..."at the beginning of upload. Also pressing the Reset-Button (before connecting) during the upload has no success.
    But the Problem is not the start of the upload. Sometimes the upload continues up to 30 percent or 50 percent. Then there is a "timeout for waiting fot packet header".

    But the upload is always ok, when I ...
    (1) use a short USB-cable (I tried various 1m long cables at various USB ports (2.0 and 3.0), but no one performs)
    (2) remove the Bottom-Plate (then a 1m cable is ok).

    BTW Is there an example Code for the 9DOF-Sensor (new in 2018 model)?
    BTW The "gift" wasn't in my development kit (does'nt matter, I have enough of them).

  • ++

  • Interesting information. I only have the one device here so can't say if the "fixes" that have worked are universal. I just put together an image to help illustrate what I was talking about on the header pins for another post.

    0_1521820543767_M5Stack MBus Header Connections.png

    I will reiterate that the noted plastic spacer on the bottom board, proto board, and 850mAh battery expansion I have were not fully seated. This resulted in slightly male pins (0.5 mmm give or take) and intermittent connections with the female headers in the MBus stack. The plastic spacer being up also acted as a stop preventing full engagement with the female sockets in the header and resulted in programming problems, use of the capacitor on the RST\GND thru the base plate, and power feed problems to the Core from the base and battery packs. While I haven't used them, I suspect I'd have had intermittent issues with all other pin functions thru the header stack without my little tune up :)

    Again, may not be a universal thing since I only have one system but I'd highly suggest anyone using the system take a few moments to seat the space shown on the assorted board. My suspicion is that part of RMR's issues sound related to the pin engagement and is why it works when the base (or other boards) are pulled off.

  • Slightly shorter male pins exposed (I thought the word, it just didn't make it to the fingers)

  • ++

  • @jimit Thanks for the Edit pointer and feedback. Good info about the power button too (like most guys, I look at manuals after I bang my head on the wall a bit).

    One update - I had separated the modules to take a look a the 850 mAhr batter board earlier today. Ended up having fits getting the M5Stack to work again when I re-stacked - even with just the bottom board and core and having the spacer on the bottom board pressed all the way down. I ended up reverting to just removing the pin spacer (that was a PIA) to see if that helped. I did manage to get things working again but it took some fussing. End of the day, I think it comes down to tolerance accumulations on the pin header, socket header, plastic assemblies and then is compounded by the tapers on the male pins.

  • @jimit
    I am using a direct USB-Connection to my Desktop-PC. A connection to my laptop has the same result.
    But there is another problem I got when using the MP9250 example software and the "Playing MP3 from SD-Card" example:
    Even when I'm just approaching to the M5stack (not touching) I often get several failures such as a reboot or a freeze. It doesn't depend wether the bottom is connected or not. I extra put a sheet of paper between my finger and the M5unit to be shure, there is no direct contact. I took a video of it, but is ist to big to upload it.
    So I think my m5stack has a hardware problem. I'd like to test it with another M5stack but I have no other one and I dont want to buy one more because I don't know if there might be the same problem.

  • Hello

    I have exactely the same problem with my M5STack I have resolved this by remove the battery part (Bottom )


  • For the M5FIre do this
    For the m5stack fire you need to follow these steps

    1. Remove all modules, leaving only the host
    2. Then try to lower the baud rate when burning
    3. If there are wires, you can short-circuit G0-GND before powering on the device and then power on again.!