ATOM-DTU-NB-IoT - modem does not respond anymore

  • Well, yes.... "AT\r" should be enough and this was even mentioned in the datasheets.

    Anyway, mostly people use tinyGSM and "AT\r\n" should work anyway.

    I tried "AT\r" - no difference, the modem remains silent. I also tried a USB-USART connection with 3.3V levels and tried different baudrates, spamming the modem with any combination of "AT\r\n" - no success.

    Normally it has autobaud, if not it should start with "RDY" - I'm not getting anything with powerup. The modems LEDs blink but thats all.

    I saw that they're translating the logic-levels from 3.3V to 1.8V. I'm not sure but these are looking completely strange to me.


    There shouldn't be any 3.3V peaks, right? The image shows my TX line, somewhere at transistor Q3. NB_RX and U1_RX are looking quite similar, so maybe the transistor is broken?

  • Hello @erazor

    I agree, I wouldn't expect 3.3 V peaks at the U1_RX side of the Q3. And yes, I guess the transistor could be broken, but it being broken in three devices - that is a bit hard to imagine.

    I never have used the TinyGsmAutoBaud code myself. I normally run all my modems with just 115200 and so far that worked just fine.

    Have you tried to measure what comes out of the modem, e.g. at transistor Q5? Maybe you can determine from that what baudrate the modem expects?


  • @felmue there is nothing. I also removed and replaced Q3 with Q5. My idea was, that maybe Atom-RX line became output and killed Q3 but that's not the case.

    Removing the Q5 completely changed nothing.

    I ordered another two modules to check the signals but I start to think the issue is in the modem.

    Maybe I come to a point where I should ask the M5 team for help. This is kinda annoying, I really like the design of the DTU.

  • Hello @erazor

    ok, I see. Yes, I think getting in touch with M5Stack support is probably best.


  • @felmue thanks for your hints and your time!

  • Global Moderator

    Hi, can you offer me that code when the modem stopped responding? To see if my DTU will meets the same issue

  • Update for anybody who's reading this.

    My previous assumption that the reset-button kills the modem seems incorrect.

    I've had another two devices and carefully did not use the reset-button at all but these modules also stopped working.

  • i can not use this code, Error:

    In file included from N:.....\nb_dtu_reset_issue-main\src\main\main.ino:21:
    c:\Users\fb\Documents\Arduino\libraries\TinyGSM\src/TinyGsmClient.h:118:2: error: #error "Please define GSM modem model"
    #error "Please define GSM modem model"
    exit status 1

    Compilation error: exit status 1

  • Hello @Felix22

    please do not use the nb_dtu_reset_issue code - it was meant to debug an issue and can change the baudrate of the SIM7020 modem.