MX Linux 19.4 Arduino IDE Copiling Error M5Stack Basic

  • I tried to compile the example "Hello World".

    compiler abort: can someone please help?

    "Arduino: 1.8.19 (Linux), Board: "M5Stack-Core-ESP32, QIO, 80MHz, Default, 921600, None"
    Traceback (most recent call last):
    File "/home/Carsten/.arduino15/packages/m5stack/tools/esptool_py/3.1.0/", line 38, in <module>
    Mehrere Bibliotheken wurden für "SD.h" gefunden
    import serial
    Benutzt: /home/Carsten/.arduino15/packages/m5stack/hardware/esp32/2.0.2/libraries/SD
    Nicht benutzt: /home/Carsten/Dokumente/arduino-1.8.19/libraries/SD
    Mehrere Bibliotheken wurden für "WiFiClient.h" gefunden
    Benutzt: /home/Carsten/.arduino15/packages/m5stack/hardware/esp32/2.0.2/libraries/WiFi
    Nicht benutzt: /home/Carsten/Dokumente/arduino-1.8.19/libraries/WiFi
    ImportError: No module named serial
    exit status 1
    Fehler beim Kompilieren für das Board M5Stack-Core-ESP32.

    Dieser Bericht wäre detaillierter, wenn die Option
    "Ausführliche Ausgabe während der Kompilierung"
    in Datei -> Voreinstellungen aktiviert wäre.

    (compile with Uno works)

  • Hi Stoni99. Perhaps you could show us the code you're trying to compile.

  • /*

    #include <M5Stack.h>

    /* After M5Core is started or reset
    the program in the setUp () function will be run, and this part will only be run once.
    在 M5Core 启动或者复位后,即会开始执行setup()函数中的程序,该部分只会执行一次。 /
    void setup(){
    M5.begin(); //Init M5Core. 初始化 M5Core
    M5.Power.begin(); //Init Power module. 初始化电源模块
    Power chip connected to gpio21, gpio22, I2C device
    Set battery charging voltage and current
    If used battery, please call this function in your project */
    M5.Lcd.print("Hello World"); // Print text on the screen (string) 在屏幕上打印文本(字符串)

    /* After the program in setup() runs, it runs the program in loop()
    The loop() function is an infinite loop in which the program runs repeatedly
    loop()函数是一个死循环,其中的程序会不断的重复运行 */
    void loop() {


  • @stoni99 said in MX Linux 19.4 Arduino IDE Copiling Error M5Stack Basic:


    OK I have compiled it with the "Board" M5Stack-Core-ESP32. Same version as you. i.e. 2.0.2.

    That "import serial" in your output is a mystery to me.
    Try updating to the latest version of the core i.e.2.0.3

  • I have updated. Another error:

    Arduino: 1.6.7 (Windows XP), Board: "M5Stack-Core-ESP32, Default 4MB with spiffs (1.2MB APP/1.5MB SPIFFS), 240MHz (WiFi/BT), QIO, 80MHz, 4MB (32Mb), 115200, Core 1, Core 1, None"

    WARNUNG: Kategorie '' in der Bibliothek ESP RainMaker ist ungültig und wird auf 'Uncategorized' festgelegt
    WARNUNG: Kategorie '' in der Bibliothek WiFiProv ist ungültig und wird auf 'Uncategorized' festgelegt
    In file included from c:\dokumente und einstellungen\carsten\lokale einstellungen\anwendungsdaten\arduino15\packages\m5stack\tools\xtensa-esp32-elf-gcc\gcc8_4_0-esp-2021r2-patch3\xtensa-esp32-elf\include\c++\8.4.0\stdlib.h:36,
    from C:\Dokumente und Einstellungen\Carsten\Lokale Einstellungen\Anwendungsdaten\Arduino15\packages\m5stack\hardware\esp32\2.0.3/tools/sdk/esp32/include/newlib/platform_include/assert.h:21,
    from c:\dokumente und einstellungen\carsten\lokale einstellungen\anwendungsdaten\arduino15\packages\m5stack\tools\xtensa-esp32-elf-gcc\gcc8_4_0-esp-2021r2-patch3\xtensa-esp32-elf\sys-include\sys\reent.h:503,
    from C:\Dokumente und Einstellungen\Carsten\Lokale Einstellungen\Anwendungsdaten\Arduino15\packages\m5stack\hardware\esp32\2.0.3/tools/sdk/esp32/include/newlib/platform_include/sys/reent.h:17,
    from c:\dokumente und einstellungen\carsten\lokale einstellungen\anwendungsdaten\arduino15\packages\m5stack\tools\xtensa-esp32-elf-gcc\gcc8_4_0-esp-2021r2-patch3\xtensa-esp32-elf\sys-include\stdio.h:60,
    from C:\Dokumente und Einstellungen\Carsten\Lokale Einstellungen\Anwendungsdaten\Arduino15\packages\m5stack\hardware\esp32\2.0.3\cores\esp32/Arduino.h:27,
    from sketch\HelloWorld.ino.cpp:1:
    c:\dokumente und einstellungen\carsten\lokale einstellungen\anwendungsdaten\arduino15\packages\m5stack\tools\xtensa-esp32-elf-gcc\gcc8_4_0-esp-2021r2-patch3\xtensa-esp32-elf\include\c++\8.4.0\cstdlib:41:10: fatal error: bits/c++config.h: No such file or directory
    #include <bits/c++config.h>
    compilation terminated.

    exit status 1
    Fehler beim Kompilieren.

    Dieser Report hätte mehr Informationen mit
    "Ausführliche Ausgabe während der Kompilierung"
    aktiviert in Datei > Einstellungen.

  • You've switched from Linux to Windows!
    Arduino 1.6.7 is quite old. I'd suggest updating to the latest. If that doesn't work then perhaps there may be a problem with the Arduino setup. You could try uninstalling and reinstalling the Arduino IDE. That's quite drastic but I can't see why you see that problem. When you remove the IDE you should also remove the 'Arduino15' folder. i.e. C:\Users(username)\AppData\Local\Arduino15
    Also, perhaps remove all the comment lines in your sketch. It will make it easier to read and see if there is a problem there.

  • I tried to make the arduino ide executable for the m5stack at the same time - Windows or Linux . It worked now on linux mx.👍