M5Go will not boot



  • Has anyone encountered a boot problem with the stock demo programs with their M5Go and if so how did you resolve it? I bought an M5Go today and was tinkering with the unit and when I clicked on the "Apps" selection and then selected the "Scan WIFI" the unit locked up and when I reset it the unit will boot to a screen that looks like the text has been truncated. It looks like lower case "rluw" but could be almost anything like PLOW or FLOW since the text appears to be just the lower part of the characters. Trying to reset or power off the unit does nothing. It goes back to this state. I've even removed the battery pack to clear the unit but once the back is reinstalled the same thing happens.
    Here's what it looks like and a close up of the text.
    M5Go
    Text closeup

    I was going to try to upload a test program but I'm running Ubuntu and the instructions for getting things to work in Linux are lacking. If I have to fight this thing this hard just to run the default demo programs I'm not that confident that I'll want to spend all the time trying to make it work if it loses its programs that easily. This thing may get returned if I can't get this sorted out soon.

    Thanks for any help anyone can provide.

    BTW, before anyone hammers me I've already checked the FAQs and searched the forums using search criteria like M5Go lockup or hung or "won't boot", etc. If this is covered somewhere please let me know how to find it using the search critera.


  • Global Moderator

    Hello, have you tried other operation system? perhaps you could burn the test firmware and see what's going on and if m5burner can find it.