RGB Led of 8Servo Hat

  • Hi M5Stackies,

    i am trying to use the RGB Led on the 8Servo Hat. No matter how and what i have tried, the Led is not working. I used Arduino, I used Uiflow, I wrote to I2C Device Hex 38, Register Hex 20 any 3 Bytes with values from 1 to 256 but no Light from the LED? And yes I switched the Batterie on :-)

    I have two of the 8Servo Hats, both show the same behavior? Servo control is working fine, reading an writing to and from the RGB Register 0x20, 0x21 an 0x22 is working fine but no reaction from the LED.

    Any Hint from your side?
    Best regards

  • Hello, what RGB LED are you using? is it a module from M5Stack or just a generic LED? could you provide some information regarding the component part and how did you plug it to your M5stack device, also, what device are you using? is it Core2?

  • @zontex Hi, I am talking about the onboard RGB Led of the 8Servo Hat (https://docs.m5stack.com/#/en/hat/hat-8servos) and I am using the M5StickC as Core device. Hope this Information is helpfull?

    Best regards

  • @krimhild58 Could you please provide the arduino code you are trying to execute so I could try to replicate it and see what's going on?

  • @zontex Hello, i am happy to tell you that i was able to solve the problem :-)

    One of my Hats has a defect LED and the code I used to test the other one was based on wrong assumptions.

    I simply set the RGB to 0xFFFFFF. But because the coprocessor on the servo-hat reminds the last active value, even after a power off, it never switched on the Led as long as I used the same value again and again. Changing the color of the RGB in a loop suddenly switched it on. Using the same code on the other Hat revealed that this one has a broken LED. Mystery solved!
    Thanks for your help so far and best regards

    @m5stack I think it would be a good idea to change the code of the 8servo hat, so that on power on, the LED is initialized with the stored values and not simply left off.

  • Hi, I just ran some test and the LED doesn't work if the lithium battery in the base is below 3.8 volts. the microprocessor wont start up and so the M5StickC can't communicate.