** [IMPORTANT] OSX BigSur update FAQ solutions **


  • Global Moderator

    Hi Guys,

    Recently a lot of customers had issue after updating or using OSX BigSur.
    We found out 2 major issues and we will keep this topic updated in case we will find more.

    File "serial/tools/list_ports_osx.py", line 32, in ValueError: dlsym(RTLD_DEFAULT, kIOMasterPortDefault): symbol not found:

    This issue caused in ESP-Tool due to pyserial that it depends on, esptool developers fixed it and so did we, we pushed new update for Arduino IDE so if you are having the same issue just delete the M5Stack library and re-install again - it should solve the issue.

    CP210X driver installation, can't confirm in settings

    This is a bug either on the driver side or OSX, the bad news is - there is no quick fix for this.
    Please follow the following thread and the comment bellow to disable security, restart your mac and modify some system files regarding the CP210X to get it fixed: click here to go to the article

    We expect silicon labs to fix it sooner or later and the normal driver installation should work as expected.

    Update Nov 30th

    We recently found out that some customers with older versions of OSX will get an error once they've updated their Arduino board library to the latest version, the error mentioned below:

    ImportError: No module named serial
    

    There are couple of solutions, first one not to use the latest version of the board manager if you have OSX lower than BigSur, use the one version before that. the only difference is the fix for BigSur.

    Second option is to install pip3 (pip for python3) and run the following command in the terminal window:

    pip3 install pyserial
    

    This should install the pyserial library and fix the issue

    We are working on a generic fix and will probably release it by next week.