M5Stack FIre Wifi can not connect

  • Good evening.

    Today I got my M5Stack Fire, and I was trying to connect with my Wifi. Sadly this does not work yet. It's screens shows: "Problem. Not Connected to: SSIDName" after trying to connect.

    • I have tried baking in the SSID / Password when I update the firmware ( and have also tried the method with using the M5Stack as a wifi accespoint + updating the credentials with my phone, but both methods fail.
    • I don't think I made a typo with the password, because I copy pasted that.
    • I do use the "_" symbol in my SSID name, could that be an issue?

    Is there some method to see why it's failing?

    For the time being I only used M5Flow to program with by the way. Luckily connecting with USB works properly.

    1. make sure your WiFi SSID not include "space" or other special symbol
    2. remove the battery bottom then try again.

  • My WIFI has some underscores ("_") symbols, because I have opted out from google using my wifi signal using “_nomap”. These is the only special character symbol I'm using. Next to that it's a bit difficult to change the SSID, because we have like 20 different devices using it.

    Is there some way to see if the name of my WIFI SIDD is the actual problem?

    Thanks for the quick reply by the way!

  • I think the underscores are indeed the issue. I just did a test in which I used my pc as a WIFI hotspot, and the M5Stack connects properly now. It's a weird thing underscores can't be used in the SSID...


  • SSID can use underscores. but esp32 wifi only support 2.4G freq. so maybe you could check the wifi freq.

  • @sjako check out the last comment in this thread https://forum.m5stack.com/topic/1252/my-m5stack-can-t-connect-to-wifi-solved you may be able to get around this issue by replacing the "_" in your url with "%5F"

  • Hello,

    this is a problem on all M5 Devices with firmware >! I have test it with M5Stack Gray and M5StickC.

    My tests:

    • firmware 1.6.0 on router Connect Box (Unitymedia / old router) - it works
    • firmware on router Vodafone Station (new router) - it works
    • firmware 1.6.0 on router Vodafone Station (new router) - no connection
    • firmware 1.6.0 on iPhone (with "_" in SSID) - it works

    I get following message on the COM monitor on router Vodafone Station:
    [534537] MQTTException -> [Errno 113] EHOSTUNREACH
    reconnect start ...

  • the problem with the Vodafone Station I also noticed the Vodafone Station is very bad also for smart home devices like Amazon Alexa, so I bought a Fritzbox 6591 and all problems are gone

  • @plusulli : This is good to know, but this is not the solution for this problem :)

    Anyway, I bought now a repeater "tp-link TL-WA854RE" from Aldi Süd. The repeater connects without problems on the Vodafone Station and the M5 devices works with firmware 1.6.0 on this repeater. So I have an workaround for now, but I hope for a real solution ...

  • I did a test with a Pycom WiPy 3.0 - it will also not connecting on the Vodafone Station :(

    It seems that some routers have issues, when connecting an ESP32.

    In the next days I am testing an Arduino sketch, instead of MicroPython.