Bitcoin / Multi Crypto Coin Ticker with 24 candlesticks chart

  • Updated Version (minor changings):

    • added cycling function: enable/disable by pressing ButtonA+ButtonC together. steps through your currencies after a certain time (default: 15sec for each currency)

    • added Timezone for Singapore (UTC+8)

    • code merged to one version, so there is no need to have different versions anymore

    • autodetect the optional room sensor and show 12pixel high sensor panel in this case temperature unit C or F and offset is set from SD-Config and not hardcoded anymore (because the M5-Stack is heating up itself it will never be accurate and has only limited expressiveness)

    last modified Nov.20.2021 15:20 CET - Version 1.0.53fix

  • I'm getting crazy. I have a SSID with spaces: I Installed it for the first time around the end of October. I updated it with the cycling function. it connected flawlessy. Yesterday I wanted to add a new pair, and now it does not connect anymore to wifi ... that's weird

  • @reddai
    hard to predict but i experienced odd behavior with reading settings when i for example forgot to eject the sd-card on pc by control center (use checkdisk on the sd card too if you forgot).
    Or maybe you have some hidden symbols from a copy paste action in your settings file or router config page. I'm not so good with ascii code but like when you see a url link with %20 for space or something. Maybe you used a complex texteditor? use simple text editor, no format options, and of course check every single sign... frustrating to not know. First i would try a fresh config file and only wifi settings. Before check your SD card. When this still fails try without space in name, if it works we have to accept that fact or better investigate that "space in name" problem of the used esp32 library

  • @frittna thanks for your help ! I did a fresh config with a formatted sd completly empty and it worked!!

  • Is there a way to use this code on Core2?

  • Can someone please share M5Burner.exe download. The new M5Burner does not allow to select the zip file to burn.

  • @yashax

    well.. i don't have a Core2 unit to test, only Core. I have read a few lines and that there is not much difference for old Core apps to run .. something changed at the power-state chip and its command for example.

    One good thing is that you can select Core2 in Arduino and compile it right away without any errors :)

    from compiler:
    Sketch uses 1225886 bytes (18%) of program storage space. Maximum is 6553600 bytes.
    Global variables use 55364 bytes (1%) of dynamic memory, leaving 4466620 bytes for local variables. Maximum is 4521984 bytes.

    BUT when you want to have Core2 board in your Arduino you need to load ESP32 Boardmanager version 1.0.6 and my code locks up with a stack overflow error for unknown reason when i use 1.0.5 or 1.0.6... not at compiling but when it connects to wifi. This was an issue a year ago and never solved it because i don't know what changings at the board library causes the conflict.
    I think a real M5-Stack freak could find the cause easy (or knows it already) because there must be many other apps i guess after 1.0.5 came out whith same problem. But since i don't know where to start i have no fix for you Core2 users atm

  • @yashax said in Bitcoin / Multi Crypto Coin Ticker with 24 candlesticks chart:

    The new M5Burner does not allow to select the zip file to burn.

    what do you mean?.. try downloading new from source and follow readme

  • This post is deleted!

  • @yashax said in Bitcoin / Multi Crypto Coin Ticker with 24 candlesticks chart:

    Thank you. What is the location of the M5Burner source?

    you find the link is in the first post

    download project:

  • @frittna
    Hi there,

    I have a Core 2 and I want to install this. I tried doing this on windows with the installer, however the SD card library isn't compatible with the Core 2, according to this post:

    Can you compile a version with a SD card library that works? This looks so cool and i really want to try this out!

  • @frankchau93
    i started from zero too so maybe give it a try and search/test if there are other compatible libraries. Since i have no core2 device and beside the (stupid) fact that i cannot use the latest boardmanager (higher than 1.0.4) on a core1 I am kind of stuck. But i guess not forever.. atm i am not really plessed with free time but we would need to know what is causing the problems with boardmanager 1.0.5 and higher first. I suspect the WIFI, the SDCard or the Websockets library. Then only minor changings in code are needed to support core2 i guess.

  • Can someone please help me figure out how to display ticker for TIME crypto coin?

  • Is it possible to have ticker rotate between several crypto coins? Like BTC for 5 seconds, the ETH for 5 seconds, in the loop.

  • @yashax

    regarding TIME token - I see 4 different tokens with that name but none of it is listed on binance.

    An optional cycling function like you're asking was added in the last version i've released a month ago.
    Scroll up or go to the github source page.
    btw: do you have a core1 unit now?

  • @frittna Yes, picked up 2 Core 1’s with stands. ))

    Regarding TIME, so if it’s not listed on Binance, it won’t work?

    Thank you for all your help.


  • @yashax
    yes, thats correct since prize data comes from the binance api only, spot markets, no derivates

  • How can I change clock from 24hr to 12hr?

    Thank you

  • @yashax 0_1642890212095_43c2805b-3de5-4119-9f31-627354773fbc-grafik.png

    you can check at line 500 in the code and simply change lines where is says "time(now)" to "timeFormat12(now)"
    this will work and will show time in am/pm mode and not in 24h mode.
    If you want to have a visualisation for am/pm too you would have to find free space first and draw something small with a the isAM() or isPM() function.

  • @frittna Thank you so much.

    What’s the while line on the chart?