Problem with Arduino IDE

  • Hi everybody,

    I try to upload my firts code to M5Stickc.
    I have done all the steps from this video:

    I tried a simple sketck like "Factory Test" from the Examples for M5stickc,
    and ensure to select the right board (M5stickc), the right port (COM3 for me) and the right upload speed (115200).

    But, when I thy to upload, I get allway the same error:

    *Error loading Python DLL: C:\Users\juana\AppData\Local\Temp_MEI90082\python27.dll (error code 5)

    Multiple libraries were found for "M5StickC.h"
    Used: C:\Users\juana\Documents\Arduino\libraries\M5StickC
    Multiple libraries were found for "Wire.h"
    Used: C:\Users\juana\AppData\Local\Arduino15\packages\esp32\hardware\esp32\1.0.3\libraries\Wire
    Multiple libraries were found for "SPI.h"
    Used: C:\Users\juana\AppData\Local\Arduino15\packages\esp32\hardware\esp32\1.0.3\libraries\SPI
    Multiple libraries were found for "FS.h"
    Used: C:\Users\juana\AppData\Local\Arduino15\packages\esp32\hardware\esp32\1.0.3\libraries\FS
    exit status -1
    Error compiling for board M5Stick-C.*

    I tried to unintall Arduino IDE, deleting all related with arduino from my harddisk, and reinstallig all again, but wtih no success

    Any idea?

  • you could try to install the latest python, and esptool