All my sticks are defective...

  • This is plain ridiculous... All my sticks wont boot up. I opened one of them to see if here is any obvious damage such as exploded battery or something... Nope. They are just plain useless on arrival.

    No matter what combination of buttons. I can erase and burn new firmwares using m5burner seemingly without a problem, if there is any it's in the burner.

    The resistor "fix" is factory pre-applied. See pics.

    No amount of usb charging with any cable or power sources will make them boot up.

    Measuring the current with ruideng usb doctor always shows ridiculous values, fluctuating wildly... See pics.

    How do you guys even get working devices given my experience...

  • @illusion hmm bit strange. I have 3 stick's and all is fine.
    Latest m5burner. Burn as stick-c speed 750000 UiFlow-1.3.2.

    No extra action was taken. As you mention burn was fine but without effect. So drivers should be fine.

  • For whatever its worth: I bought 3 to experiment with and they were all fine. I just tested 20 more that I bought for a class. 17 started up in the factory test program. The other 3 had no software installed but worked fine after I downloaded the factory test example.

  • So its solved =D

    QA should take care about this, you can use official mail support to report this.